交换机使用VRRP实现网关主备冗余

交换机使用VRRP实现网关主备冗余

Scroll Down

现在大多数网络为了增加网络的可靠性,都会要求外网出口组成主备冗余,保证单台设备故障不会对网络造成影响。这时候就需要VRRP在承担网络故障时进行设备切换。

同样VRRP在交换机、路由器和防火墙等设备都可以使用。

VRRP虚拟路由冗余协议(Virtual Router Redundancy Protocol)通过把几台路由设备联合组成一台虚拟的路由设备,将虚拟路由设备的IP地址作为用户的默认网关实现与外部网络通信。当网关设备发生故障时,VRRP机制能够选举新的网关设备承担数据流量,从而保障网络的可靠通信。

我们来使用华为设备进行实验:

1.jpg

VRRP

1,将层基本网络搭建

先配置出口交换机S3

建立VLAN

[S3]vlan b 20 10 100

配置出口IP及端口

[S3]int vlan100

[S3-Vlanif100]ip add 10.0.0.1 30

[S3]int g 0/0/4

[S3-GigabitEthernet0/0/4]port link-type access

[S3-GigabitEthernet0/0/4]port default vlan 100

配置出口默认路由

[S3]ip route-static 0.0.0.0 0.0.0.0 10.0.0.2

配置内网的VLAN接口IP

[S3]int vlan10

[S3-Vlanif10]ip add 192.168.10.2 30

[S3-Vlanif10]int vlan20

[S3-Vlanif20]ip address 192.168.20.2 30

配置内网的两个端口

[S3]int g 0/0/2

[S3-GigabitEthernet0/0/2]port link-t ac

[S3-GigabitEthernet0/0/2]port de v 10

[S3-GigabitEthernet0/0/2]int g 0/0/3

[S3-GigabitEthernet0/0/3]port link-t ac

[S3-GigabitEthernet0/0/3]port def vlan 20

配置交换机S1

[S1]

[S1]vlan B 10 30

[S1]int vlan10

[S1-Vlanif10]ip add 192.168.10.1 30

[S1-Vlanif10]int vlan30

[S1-Vlanif30]ip add 192.168.30.1 24

[S1-Vlanif30]int g 0/0/2

[S1-GigabitEthernet0/0/2]port link-type ac

[S1-GigabitEthernet0/0/2]port de vlan 10

[S1-GigabitEthernet0/0/2]int g 0/0/3

[S1-GigabitEthernet0/0/3]port link-t ac

[S1-GigabitEthernet0/0/3]port de v 30

配置交换机S2

[S2]vlan b 20 30

[S2]int vlan 20

[S2-Vlanif20]ip address 192.168.20.1 30

[S2-Vlanif20]int vlan30

[S2-Vlanif30]ip add 192.168.30.2 24

[S2-Vlanif30]

[S2-Vlanif30]int g 0/0/2

[S2-GigabitEthernet0/0/2]port link-t ac

[S2-GigabitEthernet0/0/2]port de v 20

[S2-GigabitEthernet0/0/2]int g 0/0/3

[S2-GigabitEthernet0/0/3]port link-t ac

[S2-GigabitEthernet0/0/3]port de vlan 30

配置二层交换机S4端口

[S4]vlan 30 40

[S4-vlan30]q

[S4]int g 0/0/1

[S4-GigabitEthernet0/0/1]port link-type ac

[S4-GigabitEthernet0/0/1]port de v 30

[S4-GigabitEthernet0/0/1]int g 0/0/2

[S4-GigabitEthernet0/0/2]port link-type ac

[S4-GigabitEthernet0/0/2]port de v 30

[S4]int Ethernet 0/0/4

[S4-Ethernet0/0/4]port link-type access

[S4-Ethernet0/0/4]port default vlan 40

[S4-Ethernet0/0/4]int e0/0/5

[S4-Ethernet0/0/5]port link-type ac

[S4-Ethernet0/0/5]port de v 40

[S4]int vlan30

[S4-Vlanif30]ip address 192.168.30.3 24

在S4上面开启DHCP

[S4]dhcp enable

搭建DHCP服务器

[S4]int Vlanif 40

[S4-Vlanif40]ip address 172.16.0.1 20

[S4-Vlanif40]dhcp sel interface

[S4-Vlanif40]dhcp server dns 114.114.114.114

[S4-Vlanif40]dhcp server domain-name dongzao.com

[S4-Vlanif40]dhcp server lease day 1

验证DHCP:

2.jpg

PC1可正常获取IP

2.搭建路由协议ospf

交换机S1

[S1]ospf router-id 1.1.1.1

[S1]ospf 1

[S1-ospf-1]area 0

[S1-ospf-1-area-0.0.0.0]network 192.168.30.0 0.0.0.255

[S1-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.3

交换机S2

[S2]ospf router-id 2.2.2.2

[S2-ospf-1]area 0

[S2-ospf-1-area-0.0.0.0]network 192.168.30.0 0.0.0.255

[S2-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.3

交换机S3

[S3]ospf router-id 3.3.3.3

[S3-ospf-1]area 0

[S3-ospf-1-area-0.0.0.0]

[S3-ospf-1-area-0.0.0.0]net 10.0.0.0 0.0.0.3

[S3-ospf-1-area-0.0.0.0]net 192.168.10.0 0.0.0.3

[S3-ospf-1-area-0.0.0.0]net 192.168.20.0 0.0.0.3

交换机S4

[S4]ospf router-id 4.4.4.4

[S4-ospf-1]area 0

[S4-ospf-1-area-0.0.0.0]net 192.168.30.0 0.0.0.255

[S4-ospf-1-area-0.0.0.0]net 172.16.0.1 0.0.15.255

现在我们验证一下ospf:

3.jpg

S3显示路由已经全通

4.jpg

PC2可以ping通外网地址

并且我们看到PC2是通过地下的链路到达外网的!

5.jpg

使用地下链路到达

下来我们配置VRRP

3.配置VRRP

配置交换机S1

[S1]int Vlanif 30

配置虚拟IP

[S1-Vlanif30]vrrp vrid 1 virtual-ip 192.168.30.100

设置本交换机为主设备,配置高级别优先级

[S1-Vlanif30]vrrp vrid 1 priority 200

配置故障抢占时间20秒

[S1-Vlanif30]vrrp vrid 1 preempt-mode timer delay 20

配置VRRP认证

[S1-Vlanif30]vrrp v 1 authentication-mode simple dongzao

配置交换机S2,和S1配置一样。

[S2]int vlan30

[S2-Vlanif30]vrrp vrid 1 virtual-ip 192.168.30.100

[S2-Vlanif30]vrrp vrid 1 priority 150

[S2-Vlanif30]vrrp v 1 preempt-mode timer delay 20

[S2-Vlanif30]vrrp v 1 authentication-mode simple dongzao

我们来验证:

6.jpg

S1 VRRP信息

7.jpg

S2 VRRP信息