华为三层交换机对接路由器

华为三层交换机对接路由器

Scroll Down

华为三层交换机对接路由器,三层交换机和二层交换机的区别,在于三层交换机是具有路由功能的交换机,同时可以工作在三层和二层,既可以作为接入交换也可以作为汇聚交换机。

三层交换已经具备路由功能,因此可以通过路由来使不同VLAN间通信。

1.jpg

三层交换机对接路由器

先配置交换机

<Huawei>system-view

[Huawei]sysname S1

首先,创建VLAN 10 20 30


[S1]vlan batch 10 20 30

将各个端口加入VLAN

[S1]int g0/0/1

[S1-GigabitEthernet0/0/1]port link-type access

[S1-GigabitEthernet0/0/1]port default vlan 20

因为接电脑的属于边缘接口,因此为了加速生成树汇聚时间,在末梢端口关闭生成树。

[S1-GigabitEthernet0/0/1]stp dis

在末梢接口配置开启边缘接口。

[S1-GigabitEthernet0/0/1]stp edged-port enable

[S1-GigabitEthernet0/0/1]q

[S1]int g 0/0/2

[S1-GigabitEthernet0/0/2]port link-type access

[S1-GigabitEthernet0/0/2]port default vlan 30

[S1-GigabitEthernet0/0/2]stp dis

[S1-GigabitEthernet0/0/2]stp edged-port enable

配置交换机上联路由器接口

[S1]int g 0/0/3

需要注意的是,在二层交换机VLANIF数据需要配制成trunk,但是在三层交换需要配制成access!


[S1-GigabitEthernet0/0/3]port link-type access

[S1-GigabitEthernet0/0/3]port default vlan 10

配置VLANIF接口IP

[S1]int vlan 10

[S1-Vlanif10]

[S1-Vlanif10]ip address 192.168.10.2 24

[S1]int vlan20

[S1-Vlanif20]ip address 192.168.20.1 24

[S1]int vlan 30

[S1-Vlanif30]

[S1-Vlanif30]ip add 192.168.30.1 24

在VLANIF20和VLANIF30 接口开启DHCP

[S1]int vlan 20

[S1-Vlanif20]dhcp select interface

[S1-Vlanif20]dhcp server dns-list 8.8.8.8

[S1-Vlanif20]dhcp ser lease day 1

[S1-Vlanif20]dhcp ser excluded-ip-address 192.168.20.2 192.168.20.10

[S1-Vlanif20]dhcp server domain-name dongzao.com

[S1]int vlan30

[S1-Vlanif30]dhcp select in

[S1-Vlanif30]dhcp ser lea d 1

[S1-Vlanif30]dhcp ser ex 192.168.30.2 192.168.30.10

[S1-Vlanif30]dhcp ser dns-list 8.8.8.8

最后需要,在交换上配置一条默认路由指向路由器!

[S1]ip route-static 0.0.0.0 0.0.0.0 192.168.10.1


配置路由器

<Huawei>system-view

[Huawei]sysname R1

设置接口IP


[R1]int g 0/0/01

[R1-GigabitEthernet0/0/1]ip address 100.0.0.2 24

[R1-GigabitEthernet0/0/1]q

[R1]int g 0/0/0

[R1-GigabitEthernet0/0/0]ip add 192.168.10.1 24

[R1-GigabitEthernet0/0/0]q

配置内网出口默认路由

[R1]ip route-static 0.0.0.0 0.0.0.0 100.0.0.1

配置外网指向内网路由!

[R1]ip route-static 192.168.0.0 255.255.255.0 192.168.10.2

配置NAT出口

[R1]acl 2000

[R1-acl-basic-2000]rule permit sou 192.168.0.0 0.0.255.255

[R1-acl-basic-2000]q

[R1]int g 0/0/1

[R1-GigabitEthernet0/0/1]nat outbound 2000

[R1-GigabitEthernet0/0/1]q


最后,我们检查PC1可以获取地址ping通外网地址。

2.jpg

PC1

PC2可以获取地址,ping通PC1的地址。

3.jpg

PC2

三篇的关于华为交换机对接路由器实验就讲完了

  • 《华为二层交换机对接路由器—三层转发(VLANIF接口)》
  • 《华为二层交换机对接路由器—单臂路由(子接口)》
  • 《华为三层交换机对接路由器》