华为二层交换机对接路由器—三层转发(VLANIF接口)

华为二层交换机对接路由器—三层转发(VLANIF接口)

Scroll Down

上篇《华为二层交换机对接路由器—单臂路由(子接口)》讲的是完全通过二层的子接口实现数据的跨VLAN转发。但是现实中是不推荐的,毕竟两条线路占用一个物理端口做二层数据转发,会影响整体网络性能!

这篇讲的是通过VLANIF二层交换机实现三层转发。

5.jpg

VLANIF

主要的区别在于路由器的配置,

交换机配置和上篇一样

交换机配置简单,我们先来配置:

<Huawei>system-view

[Huawei]sysname S1

建立VLAN 20 30


[S1]VLAN batch 20 30

将电脑端的接口配置access,分别划入VLAN。


[S1]interface Ethernet 0/0/2

[S1-Ethernet0/0/2]port link-type access

[S1-Ethernet0/0/2]port default vlan 20

[S1]interface Ethernet 0/0/3

[S1-Ethernet0/0/2]port link-type access

[S1-Ethernet0/0/2]port default vlan 30

配置交换机上联路由器接口,配置trunk,允许VLAN20 30通过。


[S1]int e 0/0/1

[S1-Ethernet0/0/1]port link-type trunk

[S1-Ethernet0/0/1]port trunk allow-pass vlan 20 30


这样交换机就配置完成了。

现在我们来配置路由器

<Huawei> system-view

[Huawei] sysname R1

建立VLAN 20 30


[R1] vlan batch 20 30

[R1] interface gigabitethernet 0/0/1

将以太网接口从三层模式切换到二层模式。如果接口已经是二层模式,跳过该步骤


[R1-GigabitEthernet0/0/1] portswitch

设置端口为trunk


[R1-GigabitEthernet0/0/1] port link-type trunk

[R1-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 3

[R1-GigabitEthernet0/0/1] quit

配置VLANIF20的IP地址作为PC1的网关


[R1] interface vlanif 20

[R1-vlanif20] ip address 192.168.20.1 24

配置VLANIF30的IP地址作为PC2的网关


[R1] interface vlanif 30

[R1-vlanif30] ip address 192.168.30.1 24

开启DHCP

[R1] dhcp enable

[R1] interface vlanif 20

选择端口开启DHCP


[R1-Vlanif20] dhcp select interface

[R1-Vlanif20] dhcp server dns-list 8.8.8.8

[R1] interface vlanif 30

[R1-Vlanif30] dhcp select interface

[R1-Vlanif30] dhcp server dns-list 8.8.8.8

配置公网接口的IP地址和静态路由


[R1] interface gigabitethernet 0/0/1

[R1-GigabitEthernet0/0/1] ip address 100.0.0.2 24

配置静态缺省路由的下一跳指向公网提供的IP地址100.0.0.1


[R1] ip route-static 0.0.0.0 0.0.0.0 100.0.0.1

配置NAT功能,使内网用户可以访问外网。


[R1] acl number 2001

NAT转换只对源IP地址是192.168.0.0/16网段的生效,并在接口GE0/0/2的出方向进行转换


[R1-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255

[R1-acl-basic-2001] quit

[R1] interface gigabitethernet 0/0/2

[R1-GigabitEthernet0/0/2] nat outbound 2001

VLANIF接口和子接口区别在于:

  1. VLANIF是通过VLAN接口来实现数据的转发
  2. 子接口是通过真实物理端口进行数据转发。

若果上面两种必须采用一种,建议采用VLANIF!两种配置的思想都是一样的:

  • 配置二层交换机基于接口划分VLAN,实现二层转发。
  • 配置路由器作为用户的网关,通过子接口或VLANIF接口实现跨网段的三层转发。
  • 配置路由器作为DHCP服务器,为用户PC分配IP地址。
  • 配置路由器NAT功能,使内网用户可以访问外部网络。