华为二层交换机对接路由器—单臂路由(子接口)

华为二层交换机对接路由器—单臂路由(子接口)

Scroll Down

准备写三篇关于交换机对接路由器的文章,交换机分为二层和三层,对接技术有子接口也有VLANIF,先写子接口的!

使用路由器子接口对接二层交换机,二层交换机端口只能做数据转发只能布置在接入层,不能够作为网关!这种我们也经常称之为单臂路由!

1.jpg

子接口

配置电脑和云

电脑的IP都设置为自动获取

使用一台电脑充当云

2.jpg

交换机配置简单,我们先来配置:

<Huawei>system-view

[Huawei]sysname S1

建立VLAN 20 30

[S1]VLAN batch 20 30

将电脑端的接口配置access,分别划入VLAN。


[S1]interface Ethernet 0/0/2

[S1-Ethernet0/0/2]port link-type access

[S1-Ethernet0/0/2]port default vlan 20

[S1]interface Ethernet 0/0/3

[S1-Ethernet0/0/2]port link-type access

[S1-Ethernet0/0/2]port default vlan 30

配置交换机上联路由器接口,配置trunk,允许VLAN20 30通过。


[S1]int e 0/0/1

[S1-Ethernet0/0/1]port link-type trunk

[S1-Ethernet0/0/1]port trunk allow-pass vlan 20 30


这样交换机就配置完成了。

下来我们设置路由器:

配置子接口,先建立VLAN 20 30


[R1]vlan b 20 30

进入子接口

[R1]int GigabitEthernet 0/0/0.1

置以太网子接口vlan号,封装格式为802.1q

[R1-GigabitEthernet0/0/0.1]dot1q termination vid 20

配置IP地址


[R1-GigabitEthernet0/0/0.1]ip address 192.168.20.1 24

开启ARP广播


[R1-GigabitEthernet0/0/0.1]arp broadcast enable

[R1]int GigabitEthernet 0/0/0.2

[R1-GigabitEthernet0/0/0.2]dot1q termination vid 30

[R1-GigabitEthernet0/0/0.2]ip address 192.168.30.1 24

[R1-GigabitEthernet0/0/0.2]arp b e

做到这一步,地下的电脑可以ping通子接口。

路由器开启DHCP

子接口1配置DHCP


[R1]int GigabitEthernet 0/0/0.1

[R1-GigabitEthernet0/0/0.1]dhcp select interface

[R1-GigabitEthernet0/0/0.1]dhcp server dns-list 8.8.8.8

[R1-GigabitEthernet0/0/0.1]dhcp server lease day 1

[R1-GigabitEthernet0/0/0.1]dhcp ser excluded-ip-address 192.168.20.2 192.168.20.10

子接口2配置DHCP


[R1]int GigabitEthernet 0/0/0.2

[R1-GigabitEthernet0/0/0.2]dhcp select interface

[R1-GigabitEthernet0/0/0.2]dhcp server dns-list 114.114.114.114

配置对接云的接口和出口的默认路由

<Huawei>system-view

[Huawei]sysname R1

[R1]interface GigabitEthernet 0/0/1

[R1-GigabitEthernet0/0/1]ip address 100.0.0.2 24

配置路由的出口默认路由


[R1]ip route-static 0.0.0.0 0.0.0.0 100.0.0.1

配置NAT使内网用户可以访问外网


[R1]acl 2000

[R1-acl-basic-2000]rule permit source 192.168.0.0 0.0.0.255

[R1-acl-basic-2000]q

[R1]int GigabitEthernet 0/0/1

[R1-GigabitEthernet0/0/1]nat outbound 2000

这样就配置完成了,看看结果

DHCP:

3.jpg

DHCP状态

路由状态:

4.jpg

路由表

在实际模拟器测试的时候,PC1和PC2是互通的。到路由器的出口100.0.0.2也是互通的!但是如何都ping不通100.0.0.1。

这是因为PC1ping 100.0.0.1只有去的路由,没有回来的路有!将云换成一台路由器,写一条回来的路由就全部通了!

这个实验主要用于模拟器实验,在真实环境不建议,会影响网络整体性能!

这个就写完了,有问题的欢迎地下留言!