华为交换机GVRP配置

华为交换机GVRP配置

Scroll Down

今天说一下华为交换机的GVRP配置,那就有人问GVRP都是干啥用的?

官方定义如下:

GARP(Generic Attribute Registration Protocol)协议主要用于建立一种属性传递扩散的机制,以保证协议实体能够注册和注销该属性。GARP作为一个属性注册协议的载体,可以用来传播属性。将GARP协议报文的内容映射成不同的属性即可支持不同上层协议应用。

GVRP(Generic VLAN Registration Protocol)是GARP的一种应用,用于注册和注销VLAN属性。

GARP协议通过目的MAC地址区分不同的应用。在IEEE Std 802.1Q中将01-80-C2-00-00-21分配给VLAN应用,即GVRP。

通俗的说法是:管理员在网络管理过程中,需要手工配置大量的VLAN信息,工作量大!需要耗费大量精力!这就可以通过GVRP协议,在其中一台设备上配置VLAN信息,然后通过GVRP迅速传播到整个交换网。GVRP实现动态分发、注册和传播VLAN属性,从而达到减少网络管理员的手工配置量及保证VLAN配置正确的目的。 ** 今天的实验如下:**

e1499a5d01f147aca106c94481dc2f7e.jpg

思路如下: 1. 2. 1.在交换机A和C上面分别建立VLAN10、VLAN20、VLAN30和VLAN40. 3. 4. 2.全局开启GVRP。 5. 6. 2.在交换机的相连接口开启TRUNK后,再在接口开启GVRP。

配置开始:

A交换机

第一步:建立VLAN

<Huawei>system-view

[Huawei]sysname A

[A]VLAN 10

[A-vlan10]VLAN 20

[A-vlan20]VLAN 30

[A-vlan30]

第二步:开启端口trunk

[A]interface Ethernet 0/0/1

[A-Ethernet0/0/1]port link-type trunk

[A-Ethernet0/0/1]port trunk allow-pass vlan all

第三步:全局开启GVRP

[A]gvrp

[A]dis gvrp status

Info: GVRP is enabled


第四步:接口开启GVRP

[A]interface Ethernet 0/0/1

[A-Ethernet0/0/1]gvrp

[A-Ethernet0/0/1]gvrp registration normal

这里需要说明的是接口开启后有三种注册模式分别如下

**Normal模式:允许该接口动态注册、注销VLAN,传播动态VLAN以及静态VLAN信息。

Fixed模式:禁止该接口动态注册、注销VLAN,只传播静态VLAN信息,不传播动态VLAN信息。也就是说被设置为Fixed模式的Trunk接口,即使允许所有VLAN通过,实际通过的VLAN也只能是手动创建的那部分。

Forbidden模式:禁止该接口动态注册、注销VLAN,不传播除VLAN1以外的任何的VLAN信息。也就是说被配置为Forbidden模式的Trunk接口,即使允许所有VLAN通过,实际通过的VLAN也只能是VLAN1。**

B交换机

<Huawei>system-view

[Huawei]sysname B

[B]interface GigabitEthernet 0/0/1

[B-GigabitEthernet0/0/1]port link-type trunk

[B-GigabitEthernet0/0/1]port trunk allow-pass vlan all

[B]interface GigabitEthernet 0/0/2

[B-GigabitEthernet0/0/1]port link-type trunk

[B-GigabitEthernet0/0/1]port trunk allow-pass vlan all

[B]gvrp

[B]dis gvrp status

Info: GVRP is enabled

[B]interface GigabitEthernet 0/0/1

[B-GigabitEthernet0/0/1]gvrp

[B-GigabitEthernet0/0/1]gvrp registration normal

[B]interface GigabitEthernet 0/0/2

[B-GigabitEthernet0/0/1]gvrp

[B-GigabitEthernet0/0/1]gvrp registration normal

B交换机基本和A交换配置相同我们来看一下同步结果

A交换机

5181f145437d47f8adb6a37a3bfd4963.jpg

A交换机

B交换机显示已经同步VLAN10、VLAN20、VLAN30,动态VLAN。

849e002718a947f2ae7eb0eb58c35a3d.jpg

B交换机

C交换机

<Huawei>system-view

[Huawei]sysname C

[C]VLAN 40

[C]interface Ethernet 0/0/1

[C-Ethernet0/0/1]port link-type trunk

[C-Ethernet0/0/1]port trunk allow-pass vlan all

[C]gvrp

[C]dis gvrp status

Info: GVRP is enabled

[C]interface Ethernet 0/0/1

[C-Ethernet0/0/1]gvrp

[C-Ethernet0/0/1]gvrp registration fixed

再次查看结果:

1.jpg

A交换机

A交换机显示已经收到C交换机的VLAN40,动态VLAN。

2.jpg

B交换机

B交换机显示已经收到C交换机的VLAN40,动态VLAN。

3.jpg

C交换机

C交换机仍然只有自己的VLAN40.

最后在放一张总结图:

4.jpg

最后,支持华为!