华为设备的链路聚合

华为设备的链路聚合

Scroll Down

今天主要讲解华为设备的链路聚合,这个属于基础数据交换,因此并不是只能交换机使用,同样路由器、防火墙之间,甚至是不同设备之前也可以使用,例如交换机和服务器!在日常使用中属于基础配置。

以太网链路聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高链路的可靠性。

链路聚合技术主要有以下三个优势:

增加带宽

链路聚合接口的最大带宽可以达到各成员接口带宽之和。

提高可靠性

当某条活动链路出现故障时,流量可以切换到其他可用的成员链路上,从而提高链路聚合接口的可靠性。

负载分担

在一个链路聚合组内,可以实现在各成员活动链路上的负载分担

说到这,链路聚合是分为两种的分别是:

1.jpg

链路聚合对照表

下来也不对说废话,我们来配置LACP模式的链路聚合。如下图:

2.jpg

配置要求

  1. lacp模式链路聚合。
  2. 4条链路,前三条作为动态链路,第4条作为备份链路。
  3. 其他的数据保证通畅。

开始配置

S1配置:

第一步,基本配置,将PC端口加入VLAN

<Huawei>system-view

[Huawei]sysname S1

[S1]

[S1]vlan 10

[S1-vlan10]vlan 20

[S1-vlan20]

[S1]interface GigabitEthernet 0/0/5

[S1-GigabitEthernet0/0/5]port link-type access

[S1]interface GigabitEthernet 0/0/6

[S1-GigabitEthernet0/0/6]port link-type access

[S1]vlan 10

[S1-vlan10]port GigabitEthernet 0/0/5

[S1-vlan10]vlan20

[S1-vlan20]port GigabitEthernet 0/0/6

第二部,建立LACP链路聚合

[S1]interface Eth-Trunk 1 进入Eth-Trunk视图 其中的1是链路聚合ID

[S1-Eth-Trunk1]mode lacp-static 开启lacp模式,这一步如果确定不做手工的,建议在一开始就提前配置

[S1-Eth-Trunk1]trunkport GigabitEthernet 0/0/1 将接口加入链路聚合组

[S1-Eth-Trunk1]trunkport GigabitEthernet 0/0/2

[S1-Eth-Trunk1]trunkport GigabitEthernet 0/0/3

[S1-Eth-Trunk1]trunkport GigabitEthernet 0/0/4

[S1-Eth-Trunk1]port link-type trunk 在链路聚合组开启trunk

[S1-Eth-Trunk1]port trunk allow-pass vlan all 允许VLAN通过


交换机S1和S2配置相同! ** 查看时结果:dis eth-trunk 1 **

3.jpg

dis eth-trunk 1

上图中的实例1,的状态已经UP了!

在这里我们还可以配置链路聚合的负载均衡模式:

[S1-Eth-Trunk1] load-balance src-dst-mac

4.jpg

负载分担的方式主要包括以下几种,用户可以根据具体应用选择不同的负载分担方式。

  1. 根据报文的源MAC地址进行负载分担
  2. 根据报文的目的MAC地址进行负载分担
  3. 根据报文的源IP地址进行负载分担
  4. 根据报文的目的IP地址进行负载分担
  5. 根据报文的源MAC地址和目的MAC地址进行负载分担
  6. 根据报文的源IP地址和目的IP地址进行负载分担

下面我们来配置将前3条作为主链路,第4条作为备份链路:

第一步,设置交换机lacp优先级,配置系统优先级,确定主动端,按照主动端设备的接口选择活动接口。

[S1] lacp priority 100

第二步,在S1上配置活动接口上限阈值为3,设置活动链路为3条。(默认是8条)

[S1] interface eth-trunk 1

[S1-Eth-Trunk1] max active-linknumber 3

第三步,在接口设置优先级,

[S1] interface gigabitethernet 0/0/1

[S1-GigabitEthernet0/0/1] lacp priority 100

[S1-GigabitEthernet0/0/1] interface gigabitethernet 0/0/2

[S1-GigabitEthernet0/0/2] lacp priority 100

[S1-GigabitEthernet0/0/2] interface gigabitethernet 0/0/3

[S1-GigabitEthernet0/0/3] lacp priority 100


只需要设置前三条就可,第四条优先级低,自动降为备份链路。

我们查看一下结果:

5.jpg

上面显示,最多活动端口3、已经建立的3条、第4条为未选中状态!

这步操作可以只在S1上设置,但是为了稳定性最好使用同样的配置,但是优先级必须低于S1!

我们看看S2的结果:

6.jpg

优先级要低于S1

端口的优先级为了防止端口跳动,最还配置清楚!

好了今天的就讲完了!

最后,支持华为!