华为设备的DHCP配置

华为设备的DHCP配置

Scroll Down

华为设备的DHCP配置,属于基本配置。日常会经常用到!今天就来和大家讲讲。

DHCP(DynamicHost Configuration Protocol,动态主机配置协议),在网络中主要的功能是提供IP地址给客户端使用。

DHCP 提供三种 IP 地址分配策略:

  1. 手工分配地址:由管理员为少数特定客户端(如 WWW 服务器等)静态绑定固定的 IP 地址。通过 DHCP 将配置的固定 IP 地址发给客户端。
  2. 自动分配地址: DHCP 为客户端分配租期为无限长的 IP 地址。
  3. 动态分配地址: DHCP 为客户端分配有效期限的 IP 地址,到达使用期限后,客户端需要重新申请地址。绝大多数客户端得到的都是这种动态分配的地址。

我们主要说的是动态配的方法

下面的实验,在S1上开启DHCP服务,然后为VLAN10建立地址池。

a0c965bfced04e91902adca3a0a437e5.jpg

华为设备的DHCP配置

第一步:开启DHCP服务建立地址池

<Huawei>system-view

[Huawei]sysname S1

[S1]vlan 10 建立VLAN10

[S1-vlan10]management-vlan 设置VLAN10为管理VLAN

[S1]int Vlanif 10

[S1-Vlanif10]ip address 192.168.100.1 24 为VLAN10配置IP

[S1]dhcp enable 开启S1 DHCP服务

[S1]ip pool vlan10 建立VLAN10的地址池,起名VLAN10(为了好记,设置一样的)

[S1-ip-pool-vlan10]network 192.168.100.0 mask 24 设置网络段

[S1-ip-pool-vlan10]gateway-list 192.168.100.1 配置网关地址

[S1-ip-pool-vlan10]dns-list 192.168.100.1 配置DNS地址

[S1-ip-pool-vlan10]lease day 1 设置使用祖器为1天

[S1-ip-pool-vlan10]excluded-ip-address 192.168.100.1 192.168.100.10 设置不分配地址

第二步:完成基础VLAN配置(基础配置就不在注释了)

S1配置:

[S1]interface GigabitEthernet 0/0/1

[S1-GigabitEthernet0/0/1]port link-type trunk

[S1-GigabitEthernet0/0/1]port trunk allow-pass vlan all

S2配置:

<Huawei>system-view

[Huawei]sysname S2

[S2]vlan 10

[S2]int Eth0/0/3

[S2-Ethernet0/0/3]port link-type trunk

[S2-Ethernet0/0/3]port trunk allow-pass vlan all

[S2]int e0/0/1

[S2-Ethernet0/0/1]port link-type access

[S2-Ethernet0/0/1]int e 0/0/2

[S2-Ethernet0/0/2]port link-type access

[S2]vlan 10

[S2-vlan10]port Ethernet 0/0/1

[S2-vlan10]port Ethernet 0/0/2

最后,我们来检查结果:

642de58ecb634313af3918f3c8e15f94.jpg

dis ip pool name vlan10

通过图片我们发现,S1上面已经分配出两个IP地址。

在建立的过程中,我们会发现,地址分配的特别慢,这是因为交换机开启了生成树,每当有新的电脑接入会重新生成,所有时间会长,我们只要将接电脑的端口生成树关闭,并且设置为边缘接口就可以!

关闭接口生成树

[S2]int Eth0/0/1

[S2-Ethernet0/0/1]stp disable

将接口设置为边缘接口

[S2-Ethernet0/0/1]stp edged-port enable

好了,这就说完了!