华为设备PPPOE拨号设置

华为设备PPPOE拨号设置

Scroll Down

今天有时间,给大家分享一篇,关于华为设备PPPOE配置的文章。PPPOE拨号在日常我们经常遇到,但是在企业级设备里面就不像我们普通设备,只需要输入账号就可以,需要的配置还挺多的!

这次配置实验我们选用一台华为AR3260(AR1)充当PPPOE服务器,一台华为AR2220(AR2)充当PPPOE拨号设备。

13b7586596c946f58417c59d6d163d1a.jpg

华为设备PPPOE拨号设置

  1. 思路是我们先在AR1上面建立PPPOE服务器池和认证用户账号,然后在使用AR2客户端使用AR1建立的账户进行拨号认证!
  2. 在AR2配置NAT进行上网,同时配置默认路由!

PPPOE_SERVER配置:

第一步:设置PPPOE地址池

<Huawei>sys 进入配置模式

Enter system view, return user view with Ctrl+Z.

[Huawei]sysname PPPOE_SERVER 更改设备名称

[PPPOE_SERVER]ip pool pppoe 建立PPPOE地址池

Info: It's successful to create an IP address pool.

[PPPOE_SERVER-ip-pool-pppoe]network 192.168.10.0 mask 24 设置地址池网段

[PPPOE_SERVER-ip-pool-pppoe]dns-list 192.168.10.1 设置DNS

[PPPOE_SERVER-ip-pool-pppoe]domain-name zhanzhedengdai.com 设置域名

[PPPOE_SERVER-ip-pool-pppoe]excluded-ip-address 192.168.10.1 192.168.10.10 设置不分配地址段

第二步:配置虚拟模版

[PPPOE_SERVER]interface GigabitEthernet 0/0/0 进入接口g0/0/0

[PPPOE_SERVER-GigabitEthernet0/0/0]ip address 172.16.0.1 24 配置IP

[PPPOE_SERVER-GigabitEthernet0/0/0]q 退出

[PPPOE_SERVER]interface Virtual-Template 1 开启虚拟模版配置

[PPPOE_SERVER-Virtual-Template1]ip address unnumbered interface GigabitEthernet 0/0/0 配置虚拟模版借用g0/0/0地址

[PPPOE_SERVER-Virtual-Template1]remote address pool pppoe 调用PPPOE地址池

第三步:接口调用

[PPPOE_SERVER]interface GigabitEthernet 0/0/0

[PPPOE_SERVER-GigabitEthernet0/0/0]pppoe-server bind virtual-template 1

在真实接口调用虚拟模版

第四步:建立PPPOE用户

[PPPOE_SERVER]aaa 开启AAA

[PPPOE_SERVER-aaa]local-user 123 password cipher 112233 建立用户123密码是112233

Info: Add a new user.

[PPPOE_SERVER-aaa]local-user 123 service-type ppp 将123用户使用ppp协议认证。


服务器端就配置完成了!

PPPOE_CLIENT配置:

第一步:配置拨号接入规则

<PPPOE_CLIENT>system-view 进入配置

[PPPOE_CLIENT]dialer-rule 进入拨号配置

[PPPOE_CLIENT-dialer-rule]dialer-rule 1 ip permit 设置规则1 允许IP接入(也可以设置IPV6接入)

第二步:设置拨号的接口

[PPPOE_CLIENT]interface Dialer 1 进入拨号接口

[PPPOE_CLIENT-Dialer1]dialer user 123 设置拨号用户名

[PPPOE_CLIENT-Dialer1]dialer-group 1 配置接口关联的拨号访问组,将该接口与拨号控制规则关联起来。

[PPPOE_CLIENT-Dialer1]dialer bundle 1 指定拨号接口使用dialer bundle 1

[PPPOE_CLIENT-Dialer1]ppp chap user 123 配置CHAP验证用户名

[PPPOE_CLIENT-Dialer1]ppp chap password cipher 112233 配置CHAP验证密码

[PPPOE_CLIENT-Dialer1]ip address ppp-negotiate 配置IP地址可协商属性

第三步:调用接口

[PPPOE_CLIENT]interface GigabitEthernet 0/0/0 进入接口g0/0/0

[PPPOE_CLIENT-GigabitEthernet0/0/0]pppoe-client dial-bundle-number 1 配置接口调用拨号配置

最后,我们验证一下

1533460532756afd73cc081.jpg

在这里我们发现,AR2的g0/0/0端口已经正常获取到PPPOE地址池的IP!

下来我们要配置NAT,保证上网

第一步:配置默认路由

[PPPOE_CLIENT]ip route-static 0.0.0.0 0 Dialer 1

第二步::配置nat规则

[PPPOE_CLIENT]acl number 2000 设置ACL 2000

[PPPOE_CLIENT-acl-basic-2000]rule permit source 192.168.10.0 0.0.0.255 允许192.168.10.0网段通行

[PPPOE_CLIENT]interface Dialer 1 进入拨号接口

[PPPOE_CLIENT-Dialer1]nat outbound 2000 设置NAT调用规则。

这样就配置完成了!

最后,支持华为!