H3C的ospf多区域间隔主干区域实验

H3C的ospf多区域间隔主干区域实验

Scroll Down

这几天忙一直没有发文章,主要是自己换工作了,新工作主要是华三的设备,自己本身是思科的工程师。就逮住时间赶紧练练。

思科和华为、华三的纠葛就不说了,现在使用华三的设备,大部分的思科的命令都是可以直接用的。也可能是思科做系统命令时,优先使用了简洁的单词作为命令,所以嘛。感觉还是思科的好用,单从字面就能知道意思。华三的命令就有些别扭,比如show和display、no和undo等。

下面进入今天的正题:H3C的ospf多区域间隔主干区域实验。图中路由由左往右依次是r1、r2、r3.

1533455309794096996eb7c.jpg

H3C的ospf多区域间隔主干区域实验

实验本身不是从事这个行业的都会感觉枯燥,自己就简介,快速说明。 首先是设备的开局常用配置。这个所有设备开始都是一样的。

<h3c> system-view //进入系统视图

[h3c]hostname r1 //更改设备名称

[r1]super pasword simple 123456 //设置设备密码为123456

[r1]local-user admin //添加用户

[r1-luser-admin]password simple admin //为用户设定密码

[r1-luser-admin]service-type telnet //指定用户类型

[r1-luser-admin]quit //退出

[r1]telnet service enable //启用telnet

[r1]user-interface vty 0 4 //进入vty

[r1-line-vty0-4]authentication-mode password //开启密码认证

[r1-line-vty0-4]set authentication password simple 123456 //设置密码123456

[r1-line-vty0-4]user-role level-3 //用户等级3

[r1-line-vty0-4]idle-timeout 5 0 //配置超时时间

[r1-line-vty0-4]exit //退出


上面这部分通用部分都会用到。

下面配置接口

[r1]interface GigabitEthernet 0/0 //进入物理0/0接口

[r1-GigabitEthernet0/0]ip address 192.168.20.1 24 //设置IP地址

[r1-GigabitEthernet0/0]no shutdown //开启端口

[r1-GigabitEthernet0/0]duplex full //设置全双工

[r1-GigabitEthernet0/0]speed auto //设置速率

[r1-GigabitEthernet0/0]interface LoopBack 1 //进入逻辑接口 1

[r1-GigabitEthernet0/0]ip address 172.16.0.1 255.255.0.0 //设置IP地址和上面的表达不同,都可以设置。

[r1-GigabitEthernet0/0]no shutdown //开启端口

[r1-GigabitEthernet0/0]duplex full //设置全双工

[r1-GigabitEthernet0/0]speed auto //设置速率

端口设置方法都是一模一样的,我就不多写出来其他的。

OSPF的路由设置

[r1]ospf 1 router-id 1.1.1.1 //建议这一步,一定要第一个输入!

[r1-ospf-1]area 1 //设置区域1

[r1-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0 //宣布网段 网络号+掩码反码

[r1-ospf-1-area-0.0.0.1]network 172.16.0.0 0.0.255.255

[r1-ospf-1-area-0.0.0.1]area 2 //设置区域2

[r1-ospf-1-area-0.0.0.2]network 192.168.20.0 0.0.0.255

[r1-ospf-1-area-0.0.0.2]network 192.168.10.0 0.0.0.255

[r1-ospf-1-area-0.0.0.2]network 192.168.30.0 0.0.0.255

三台路由都按照同样的方法,把OSPF 路由设置好。

  1. 设置好以后会发现区域area0、area2、area4.是可以正常通讯。但是area1和area4、area5无法通讯,同样area5和area1、area4通讯。
  2. 原因是因为ospf只有area0是骨干区域,所有区域要必须连接area0才能由路由,因此这时候就需要把area1和area0打通即可。
  3. 这时候就需要使用虚链路 area1和area0配置如下:

R1的设置

[r1-ospf-1]area 2 //进入区域2 因为area2站在area1和area0中间因此需要在area2区域打通!

[r1-ospf-1-area-0.0.0.1]vlink-peer 2.2.2.2 //虚链路设置,需要直到对方router ID。

R2的设置

[r1-ospf-1]area 2 //进入区域2 同样还要进入area2进行设置

[r1-ospf-1-area-0.0.0.1]vlink-peer 1.1.1.1//虚链路设置,需要直到对方router ID。

设置完可以使用**show ospf vlink **查看虚链路状态。 15334598703268b306bcfba.jpg

R1 上的 show ospf vlink

1533459961949b1e543f002.jpg

R2 上的 show ospf vlink

最后在查看一下,设备的路由状况

只查看ospf路由状况** show ospf routing**

15334602299993ed50c5912.jpg

R2 上的 show ospf routing

只查看全部路由状况 show ip routing-table

15334605326292a5fbba736.jpg 1533460532756afd73cc081.jpg

R2上的show ip routing-table

这样整个实验就完成了。

注意有以下几点:

ospf必须有骨干区域,也就是area0. 所有的区域必须和area0 连接!或者虚链路连接。 虚链路不能穿越多个区域,也不能穿越末节区域,只能穿越标准的非骨干区域。